tauri@2.0.0-beta.24
此内容尚不支持你的语言。
New Features
Enhancements
a7354f9a8
(#10171 by @amrbashir) MarkAppHandle::restart
andprocess::restart
as diverging functions.
Bug Fixes
4c239729c
(#10167 by @amrbashir) Fix deserialization of raw invoke requests when usingisolation
pattern.55733aba9
(#10176 by @lucasfernog) MovePluginApi::register_ios_plugin
behind thewry
Cargo feature asWebview::with_webview
is only available when that feature is enabled.
Dependencies
- Upgraded to
tauri-macros@2.0.0-beta.19
- Upgraded to
tauri-build@2.0.0-beta.19
- Upgraded to
tauri-runtime-wry@2.0.0-beta.20
- Upgraded to
tauri-utils@2.0.0-beta.19
- Upgraded to
tauri-runtime@2.0.0-beta.20
Breaking Changes
-
ba9590aa9
(#9640 by @amrbashir) AddedEmitter
andListener
traits that defines what an emitter or a listener can do, this however comes with a few breaking changes:- Removed
Manager::listen_any
, useListener::listen_any
instead. - Removed
Manager::once_any
, useListener::once_any
instead. - Removed
Manager::unlisten
, useListener::unlisten
instead. - Removed
Manager::emit
, useEmitter::emit
instead. - Removed
Manager::emit_to
, useEmitter::emit_to
instead. - Removed
Manager::emit_filter
, useEmitter::emit_filter
instead. - Removed
App/AppHandle::listen
,WebviewWindow::listen
,Window::listen
andWebview::listen
, useListener::listen
instead. - Removed
App/AppHandle::once
,WebviewWindow::once
,Window::once
andWebview::once
, useListener::once
instead. - Removed
App/AppHandle::unlisten
,WebviewWindow::unlisten
,Window::unlisten
andWebview::unlisten
, useListener::unlisten
instead.
- Removed
-
261c9f942
(#10170 by @amrbashir) RenamedDragDropEvent
enum variants to better convey when they are triggered:DragDropEvent::Dragged
->DragDropEvent::Enter
DragDropEvent::DragOver
->DragDropEvent::Over
DragDropEvent::Dropped
->DragDropEvent::Drop
DragDropEvent::Cancelled
->DragDropEvent::Leave
This also comes with a change in the events being emitted to JS and Rust event listeners:
tauri://drag
->tauri://drag-enter
tauri://drop-over
->tauri://drag-over
tauri://drop
->tauri://drag-drop
tauri://drag-cancelled
->tauri://drag-leave
-
2b1ceb40d
(#10229 by @amrbashir) Renamed the JSgetCurrent
andgetAll
functions to a clearer name to avoid ambiguity:getCurrent
inwindow
module has been renamed togetCurrentWindow
getCurrent
inwebview
module has been renamed togetCurrentWebview
getCurrent
inwebviewWindow
module has been renamed togetCurrentWebviewWindow
getAll
inwindow
module has been renamed togetAllWindows
getAll
inwebview
module has been renamed togetAllWebviews
getAll
inwebviewWindow
module has been renamed togetAllWebviewWindows
-
57612ab24
(#10139 by @Brendonovich) AddTSend
generic toipc::Channel
for typesafesend
calls and type inspection intauri-specta
© 2024 Tauri Contributors. CC-BY / MIT